Prima guida, come installare IPFire su ALIX
è stata realizata la prima guida, come installare IPFire su un dispositivo ALIX
per chi fosse interessato puo visionare tutta la guida a questo link
è stata realizata la prima guida, come installare IPFire su un dispositivo ALIX
per chi fosse interessato puo visionare tutta la guida a questo link
È nata la community IPFire Italia come Supporto volontario e collaborativo per la piattaforma IPFire® in italiano, in occasione con il rilascio della versione IPFire 2.19 - Core Update 103 released scaricabile dal sito ufficiale IPFire.org
Chiunque voglia collaborare può prendere contatto con lo staff tramite il modulo contatti
L'ora di sistema di IPFire può essere sincronizzata con un server time. Per fornire un'ora precisa alla rete locale, IPFire può anche ospitare un NTP server, ma questo non è attivato per impostazione predefinita. Puoi attivarlo tramite l'interfaccia web.

Queste opzioni forniscono l'ora alla rete locale e forzano anche una sincronizzazione all'avvio.
È inoltre possibile specificare quando IPFire deve sincronizzare l'ora con il server NTP specificato.
Le opzioni di sincronizzazione disponibili sono:

Questo è stato scelto in modo che l'ora sia sincronizzata una volta al giorno.
Per coloro che preferiscono impostare l'ora manualmente, è possibile utilizzare il seguente comando sulla console su IPFire:
ntpdate 0.ipfire.pool.ntp.org
Se qui appare un messaggio di errore, spegnere e riaccendere il time server con:
/etc/init.d/ntp stop
/etc/init.d/ntp start
potrebbe essere utile.
In caso di esito negativo, è possibile impostare l'ora anche manualmente con:
date --set "05/13/2010 09:45:00"
(Il formato sopra dovrebbe essere mm/gg/aaaa hh:mm:ss)
Se il tempo deve poi essere passato al BIOS, inserire:
hwclock --systohc
dalla Consolle.
Utilizzo di IPFire come origine dell'ora per Windows
Innanzitutto, abilita questa impostazione:

Ora configura Windows con l'indirizzo del time server (IPFire).
Una volta configurato, Windows avrà questo aspetto:

Utilizzo di IPFire come sorgente dell'ora per Mac OS
Su IPFire WUI abilita Fornire l'ora alla rete locale (Servizi -> Time Server) come illustrato sopra.
Sul Mac vai su Data e ora (Preferenze di Sistema -> Data e ora -> scheda Data e ora).
Fare clic su Imposta data e ora automaticamente , quindi inserire l'indirizzo IPFire.

Server NTP
Come server NTP sulla rete sono presenti innumerevoli
Quelli che definiscono l’orario per l’Italia sono quelli del INRiM (Istituto Nazionale di Ricerca Meteorologica) raggiungibili a questi indirizzi https://www.inrim.it/it
|
Nome |
Indirizzo IPv4 |
Indirizzo IPv6 |
Servizi disponibili |
|
ntp1.inrim.it |
193.204.114.232 |
2001:760:2602::232 |
NTP (RFC 5905) |
|
ntp2.inrim.it |
193.204.114.233 |
2001:760:2602::233 |
NTP (RFC 5905) |
|
time.inrim.it |
193.204.114.105 |
2001:760:2602::105 |
NTP (RFC 5905), TIME (RFC 868), |
|
Operatore |
Indirizzo(i) |
Hostname |
|
Anycast |
||
|
91.239.100.100 |
anycast.uncensoreddns.org |
|
|
2002:d596:2a92:1:71:53:: |
||
|
1.1.1.1 |
cloudflare-dns.com |
|
|
1.0.0.1 |
||
|
2606:4700:4700::1111 |
||
|
2606:4700:4700::1001 |
||
|
185.222.222.222 |
dot.sb |
|
|
45.11.45.11 |
||
|
2a09:: |
||
|
2a11:: |
||
|
74.82.42.42 |
||
|
2001:470:20::2 |
||
|
8.8.8.8 |
dns.google |
|
|
8.8.4.4 |
||
|
Germany (DE) |
||
|
81.3.27.54 |
recursor01.dns.ipfire.org |
|
|
2001:678:b28::54 |
||
|
81.3.27.54 |
recursor01.dns.lightningwirelabs.com |
|
|
2001:678:b28::54 |
||
|
Denmark (DK) |
||
|
89.233.43.71 |
unicast.uncensoreddns.org |
|
|
2a01:3a0:53:53:: |
||
|
Spain (ES) |
||
|
109.69.8.51 |
||
|
France (FR) |
||
|
80.67.169.12 |
||
|
80.67.169.40 |
||
|
2001:910:800::12 |
||
|
2001:910:800::40 |
||
|
Netherlands (NL) |
||
|
80.80.80.80 |
||
|
80.80.81.81 |
||
|
United Kingdom (UK) |
||
|
194.187.251.67 |
||
|
United States (US) |
||
|
198.101.242.72 |
||
|
23.253.163.53 |
||
|
Comcast / Xfinity |
75.75.75.75 |
|
|
75.75.76.76 |
||
|
38.132.106.139 |
||
|
156.154.70.1 |
||
|
156.154.71.1 |
||
|
204.117.214.10 |
||
|
199.2.252.10 |
||
|
204.97.212.10 |
||
|
64.6.64.6 |
||
|
64.6.65.6 |
||
Servizio DNS su TLS
|
Operatore |
Indirizzo(i) |
DNS over TLS Hostname |
|
Anycast |
||
|
91.239.100.100 |
anycast.uncensoreddns.org |
|
|
2002:d596:2a92:1:71:53:: |
||
|
1.1.1.1 |
cloudflare-dns.com |
|
|
1.0.0.1 |
||
|
2606:4700:4700::1111 |
||
|
2606:4700:4700::1001 |
||
|
5.1.66.255 |
anycast01.ffmuc.net |
|
|
2001:678:e68:f000:: |
||
|
5.1.66.255 |
dot.ffmuc.net |
|
|
2001:678:e68:f000:: |
||
|
185.222.222.222 |
dns.sb |
|
|
185.184.222.222 |
||
|
2a09:: |
||
|
2a09::1 |
||
|
8.8.8.8 |
dns.google |
|
|
8.8.4.4 |
||
|
Austria (AT) |
||
|
146.255.56.98 |
dot1.applied-privacy.net |
|
|
2a01:4f8:c0c:83ed::1 |
||
|
Canada (CA) |
||
|
199.58.83.33 |
dns.cmrg.net |
|
|
2001:470:1c:76d::53 |
||
|
Switzerland (CH) |
||
|
185.95.218.42 |
dns.digitale-gesellschaft.ch |
|
|
185.95.218.43 |
||
|
2a05:fc84::42 |
||
|
2a05:fc84::43 |
||
|
Germany (DE) |
||
|
5.9.164.112 |
dns3.digitalcourage.de |
|
|
81.3.27.54 |
recursor01.dns.ipfire.org |
|
|
2001:678:b28::54 |
||
|
81.3.27.54 |
recursor01.dns.lightningwirelabs.com |
|
|
2001:678:b28::54 |
||
|
Denmark (DK) |
||
|
89.233.43.71 |
unicast.uncensoreddns.org |
|
|
2a01:3a0:53:53:: |
||
|
Finland (FI) |
||
|
95.216.24.230 |
fi.dot.dns.snopyta.org |
|
|
2a01:4f9:2a:1919::9301 |
||
|
France (FR) |
||
|
Neutopia |
89.234.186.112 |
dns.neutopia.org |
|
2a00:5884:8209::2 |
||
|
Luxembourg (LU) |
||
|
158.64.1.29 |
kaitain.restena.lu |
|
|
2001:a18:1::29 |
||
|
Netherlands (NL) |
||
|
185.246.188.51 |
nl.resolv.flokinet.net |
|
|
2a06:1700:3:11::1 |
||
|
185.49.141.37 |
getdnsapi.net |
|
|
2a04:b900:0:100::37 |
||
|
Surfnet |
145.100.185.17 |
dnsovertls2.sinodun.com |
|
145.100.185.18 |
dnsovertls3.sinodun.com |
|
|
2001:610:1:40ba:145:100:185:17 |
||
|
2001:610:1:40ba:145:100:185:18 |
||
|
Romania (RO) |
||
|
185.247.225.17 |
ro.resolv.flokinet.net |
|
|
2a06:1700:0:36::1 |
||
|
United States (US) |
||
|
Comcast / Xfinity (beta) |
96.113.151.145 |
dot.xfinity.com |
Questi provider non sono consigliati per l'uso con IPFire perché non supportano DNSSEC o manomettono il traffico DNS in altro modo, ad esempio filtrando pubblicità, malware o materiale pornografico.
Sebbene esista un caso d'uso legittimo per quest'ultimo, tale filtraggio interrompe DNSSEC, essendo indistinguibile da un avversario dal punto di vista tecnico.
|
Operatore |
Indirizzi IP |
|
139.99.176.64 |
|
|
2a0d:2a00:1::2 / 185.228.168.9, 2a0d:2a00:2::2 / 185.228.169.9 |
|
|
94.130.180.225 / 2a01:4f8:1c0c:40db::1, 78.47.64.161 / 2a01:4f8:1c17:4df8::1, dns-dot.dnsforfamily.com, https://dns-doh.dnsforfamily.com/dns-query |
|
|
8.26.56.26, 8.20.247.20 |
|
|
176.9.93.198, 176.9.1.117, 2a01:4f8:151:34aa::198, 2a01:4f8:141:316d::117 |
|
|
45.55.155.25, 104.236.210.29 |
|
|
37.235.1.174, 37.235.1.177 |
|
|
81.218.119.1, 09.88.198.133 |
|
|
194.8.57.12 |
|
|
208.67.222.222, 208.67.220.220, 208.67.220.222, 208.67.222.220 |
|
|
51.89.30.51, 51.89.93.25, 2001:41d0:701:1100:0:0:0:39cc |
|
|
9.9.9.9, 149.112.112.112, 9.9.9.10, 149.112.112.10 |
|
|
130.59.31.248 / 2001:620:0:ff::2, 130.59.31.251 / 2001:620:0:ff::3 |
|
|
77.88.8.88, 77.88.8.2 |
|
|
195.46.39.39, 195.46.39.40 |
|
|
Level 3 / CentryLink / Verizon |
4.2.2.1, 4.2.2.2, 4.2.2.3, 4.2.2.4, 4.2.2.5, 4.2.2.6 |
|
SkyDNS |
193.58.251.251 |
|
New Nations |
5.45.96.220 |
|
146.185.167.43 |
Informazioni sulla posizione e sullo stato DNSSEC
La posizione dei server è stata dichiarata utilizzando il database IPFire Location. Tuttavia, potrebbe essere possibile che la posizione sia errata (o sia stata modificata nel frattempo).
I server contrassegnati con "Anycast" utilizzano anycast in modo che il traffico venga instradato alla più vicina delle numerose istanze presenti sulla rete. Di conseguenza, non è possibile determinare l'esatta ubicazione dei server. Peggio ancora, le diverse configurazioni delle istanze Anycast non possono essere determinate come affidabili.
Considerazioni sulla sicurezza e sulla privacy
Un server DNS ha una funzione molto potente nella topologia di rete. Tieni presente che potrebbe registrare le tue query (che è un'enorme perdita di informazioni).
Inoltre, non tutti i server DNS sopra elencati restituiscono comunque risposte corrette. Alcuni restituiscono errori per siti dannosi.
Per motivi di sicurezza, è necessario utilizzare server DNS che supportano DNSSEC. Per motivi di privacy e disponibilità, evitare di utilizzare i server DNS di un solo provider.
L’interfaccia BLU è progettata per separare la LAN dalla WirelessLAN “o WLAN”
Per impostazioni predefinite IPFire controlla l’accesso di tutti i dispositivi che cercano di connettersi alla linea Blu utilizzando il filtro degli indirizzi MAC.
Cioè significa che tutti i lease DHCP devono essere approvati manualmente nell’interfaccia web di IPFire, prima di poter accedere alla rete ed ovviamente anche l’interfaccia WUI della stessa rete Blu
Questo controllo è separato da qualunque filtro o protezione che puoi aver imposto alla tua rete blu
Per abilitare un client a poter navigare è necessario accedere all’interfaccia web e abilitarlo
Esempio (senza DHCP su blu ): 00:13:02:XX:XX:XXè l'indirizzo MAC del client WLAN e il client deve utilizzare l'IP 192.168.49.1.
Accedi a questa pagina tramite il menu Firewall --> Blue Access

Disabilita il filtro degli indirizzi MAC
Per disabilitare il filtraggio degli indirizzi MAC e consentire a tutti i client connessi a blue l'accesso a Internet, è necessario modificare inserendo un device con questi parametri
Esempio se la rete Blu e la subnet mask dell’interfaccia di rete blu è 172.16.1.0 a 172.16.1.255 ossia 172.16.1.0/24
È necessario inserire un client con questi parametri
Source IP inserire 172.16.1.0/24, MAC address lasciare vuoto

Nota: la disattivazione del filtro degli indirizzi MAC non disattiva la crittografia WLAN
Protocolli Qualsiasi tipo di informazione scambiata tra dispositivi attraverso una rete è regolata da regole e convenzioni che possono essere stabilite in specifiche tecniche denominate standard di protocollo di comunicazione. La natura di una comunicazione, i dati effettivi scambiati e gli eventuali comportamenti dipendenti dallo stato, sono definiti da specifiche. I protocolli sono obbligatori per qualsiasi tipo di comunicazione all'interno delle reti di computer e possono essere raggruppati in protocolli di rete e protocolli applicativi .
I protocolli di rete o i protocolli di comunicazione vengono utilizzati per gestire i flussi di informazioni e il meccanismo per la comunicazione tra i sistemi interessati. Un protocollo di rete molto semplice e importante è il protocollo Internet (IP). È responsabile della consegna dei pacchetti di rete tra utenti e sistemi remoti. Per questo processo sono necessarie molte informazioni, le più importanti sono gli indirizzi IP dei dispositivi.
Sulla base dell'indirizzo IP e di informazioni aggiuntive, IP offre un servizio per fornire i dati sul modo migliore per raggiungere la destinazione richiesta. Durante l'intero processo, l'IP interagisce con altri protocolli (protocolli di servizio) utilizzati per trasportare le informazioni principali al target. Questo processo funziona in background, quindi un utente non nota delle informazioni trasferite, a meno che non utilizzi un software speciale come gli sniffer di rete.
I seguenti protocolli di comunicazione possono essere selezionati nella WUI del firewall di IPFires per controllare lo scambio di dati tra uno o più dispositivi o reti.
Il T ransmission C ontrol P rotocol è uno dei protocolli più importanti, utilizzato sulle reti locali o su Internet.
TCP è progettato come un protocollo affidabile end-to-end orientato alla connessione per adattarsi a una gerarchia stratificata di protocolli che supportano applicazioni multi-rete. TCP utilizza un Threeway Handshake per stabilire nuove connessioni e un'operazione simile per terminare quelle esistenti.
Fornisce un meccanismo per l'integrità dei dati sulle connessioni stabilite ed è in grado di ritrasmettere sequenze di pacchetti danneggiati o persi in caso di errori.
Il U ser Datagramm protocollo è un semplice protocollo di livello di trasporto senza connessione. UDP fornisce un servizio per inviare dati con un minimo di specifiche del protocollo. UDP non fornisce alcuna funzione per ritrasmettere pacchetti rotti o persi. Tuttavia in alcuni casi UDP è una scelta migliore rispetto a TCP a causa di un minore utilizzo delle risorse quando si trasmettono solo una piccola quantità di dati.
I essage nternet C ontrol M rotocol P offre una serie di messaggi di errore e di controllo tra due o più dispositivi di rete. Con l'aiuto del protocollo ICMP possono scambiare informazioni sullo stato della rete tra di loro, quindi ICMP è un aiuto importante per diagnosticare i problemi di rete.
Esistono diversi tipi di pacchetti ICMP. Quelli importanti sono ICMP_ECHO_REQUEST e ICMP_ECHO_REPLY. Vengono utilizzati per verificare se un host o un dispositivo di rete è attivo e accessibile. Un elenco completo di tutti i tipi di ICMP può essere trovato nell'RFC 792 o effettuando una ricerca in rete.
Il protocollo di gestione . a gruppi multicast dei gruppi Internet viene utilizzato dagli host e dai router adiacenti sulle reti IP per stabilire l'appartenenza IGMP viene utilizzato per lo streaming online di video e giochi e consente un uso più efficiente delle risorse quando si supportano questi tipi di applicazioni.
L' di autenticazione header è un protocollo di sicurezza in IPSec che fornisce l'integrità senza connessione e l'autenticazione dell'origine dei dati dei pacchetti IP. Il protocollo AH protegge il payload IP e i campi di intestazione del datagramma IP.
ESP, l' E ncapsulating S Payload ecurity fornisce riservatezza, autenticazione dell'origine dei dati, integrità senza connessione e un servizio anti-replay. ESP è come AH una parte di IPSec ed è responsabile della crittografia dei dati.
G eneric R oute Encapsulation è un semplice protocollo di tunneling che supporta una varietà di tipi di pacchetti di protocollo per instradarli all'interno di tunnel IP. GRE è correlato a IPIP ma può anche trasportare pacchetti multicast o IPv6. GRE fornisce una connessione privata senza stato ma non utilizza alcuna crittografia dei dati.
L'incapsulamento IPv6 è un meccanismo di transizione Internet per la migrazione dal protocollo Internet versione 4 (IPv4) al protocollo IP di nuova generazione (IPv6). Utilizza il tunneling per incapsulare il traffico IPv6 su collegamenti IPv4 configurati in modo esplicito, a volte questa operazione è nota anche come 6in4 o protocollo 41.
IP in IP fornisce un meccanismo per incapsulare un'intestazione IP con un'intestazione IP esterna per il tunneling. La tecnica di incapsulamento è abbastanza semplice. Un'intestazione IP esterna viene aggiunta prima dell'intestazione IP originale. Tra di loro ci sono altre intestazioni per il percorso, come intestazioni di sicurezza specifiche per la configurazione del tunnel.
L'intestazione IP esterna Source e Destination identificano gli "endpoint" del tunnel.
I protocolli applicativi vengono utilizzati in combinazione con i protocolli di rete per trasmettere informazioni specifiche dell'applicazione. Nella maggior parte dei casi utilizzano TCP/IP o UDP per trasportare le informazioni richieste. flussi
A volte il contenuto trasportato per un'applicazione è "visibile" per l'utente, come l'HTTP (Hyper-Text-Transfer-Protocol) utilizzato per mostrare questa pagina Web sul browser. Un altro protocollo molto popolare è SIP (Session-Initiation-Protocol) che viene utilizzato per stabilire chiamate telefoniche tra sessioni VOIP (Voice-over-IP).
Esistono molti protocolli applicativi per diversi servizi e applicazioni, per una migliore comprensione e una facile gestione nella GUI di IPFire Firewall li chiamiamo Servizi .
Pagina 15 di 15